Page 6 of 7 FirstFirst 1234567 LastLast
Results 251 to 300 of 342

Soulstorm Race Unlocker

  1. #251
    juland70
    Guest
    Does this work with DC as well i am trying to unlock IG but i can't find the DC unlocker. Does The SS unlocker also unlock DC races??

  2. #252
    Softie. Big One. Danustar's Avatar
    Join Date
    Dec 2007
    Location
    Standing on the promises
    Not sure but either way you won't get IG from DC.

  3. #253
    juland70
    Guest
    sorry didn't add to much detail i have a WA cd key but i don't have the dics that is why i need the race unlocker!!!

  4. #254
    Quote Originally Posted by juland70
    sorry didn't add to much detail i have a WA cd key but i don't have the dics that is why i need the race unlocker!!!
    Although you really could stick with Soulstorm now...
    I will make you a Unlocker for Dark Crusade IF you promise to send me a god damned picture postcard. I am a little pissed, because no one has honored my request for some beer although some people promised :-(

  5. #255
    Lenon
    Guest
    Can anyone make a mirror of unlocker please?

    I cannot dload from this german sever, 24h to manny connections, and filed MySQL whne login in.

  6. #256
    Member Inquisitoriae's Avatar
    Join Date
    Oct 2004
    Location
    Ordo Malleus
    No problem downloading from it now.
    Want to zoom out further? Try this camera mod.
    Faith in the Emperor is its own reward.

  7. #257
    i don't have any troubles either.

  8. #258
    Lenon
    Guest
    Uh I dload from second link where source is.

    Where I should send beer?

  9. #259
    jarthel
    Guest
    I can someone please explain what does this file do? I know it's to "unlock a race" but what does that mean?

    thank you very much!

  10. #260
    Example:
    You have all versions of Dawn of War aka:
    Dawn of War
    Dawn of War: Winter Assault
    Dawn of War: Dark Crusade
    Dawn of War: Soulstorm

    So, if you would like to play Soulstorm in multiplayer with let's say Imperial Guards, you would have to install Dawn of War and Dawn of War: Winter Assault, although not a single game file is needed by Soulstorm meaning you are wasting a LOT of disk space if you install every version of DoW just to be able to play all the races you want. I don't have exact figures, but i think you save something close to 10gb of disk space.
    The Unlocker simply circumvents this by providing the "are there any older versions of DoW installed"-check of soulstorm what it needs:the necessary registry entries and valid exe files with the names of the old files.

    The Unlocker does NOT allow you to play online with all races, if you don't own a legal copy of the game (you need a valid cd-key to be precise).

  11. #261
    jarthel
    Guest
    thank you for the explanation!

  12. #262
    Follow the Sign Rotlung's Avatar
    Join Date
    Mar 2008
    Location
    Singapore is a fine city!
    If I'm not wrong, you cannot unlock IG if you only have the Winter Assault CD-key - you need to have both DoW and DoW: WA CD-keys. I could be wrong though, just a warning.
    Quote Originally Posted by chelovek_veliki
    Three FW squads plus Pathfinders plus snares and your base will be as unapproachable as I was by girls in high school.

  13. #263
    Schiannath
    Guest
    hey man
    thanks a million for this aye
    saved me ~10GB hdd space and ~an hour of install time
    your a legend

    ps id send you beer but you didnt give an address

  14. #264
    passing through
    Guest
    Before I use this, there is something I would like to know. When I look in the registery under hkey_localmachine > Software > THQ and when I select the games, I see no entry for CDKeys. I would like to know before using this that I will be able to edit the registry if need be.

  15. #265
    you will be able to.

  16. #266
    passing through
    Guest
    they'll show up after I use the unlocker?

  17. #267
    Follow the Sign Rotlung's Avatar
    Join Date
    Mar 2008
    Location
    Singapore is a fine city!
    What's stopping you from editing the registry before and after using the program?

    Edit: All the entries would be there if you used the unlocker correctly.

  18. #268
    passing through
    Guest
    There isn't actually and cdkey entries in the registry that I can see to edit. Not even for Soulstorm.

  19. #269
    no, they play hide and seek with you >.<
    of course they show up.

    if you don't have entries for Soulstorm at all, it isn't installed (correctly).

  20. #270
    Follow the Sign Rotlung's Avatar
    Join Date
    Mar 2008
    Location
    Singapore is a fine city!
    If there are no such entries, the unlocker will create them, I believe. I believe the entry is missing, not the Soulstorm folder entry in the registry that's missing, right?

  21. #271
    passing through
    Guest
    The folders ar ethere, yea. There's just no cdkey for soulstorm :P

  22. #272
    passing through
    Guest
    Peh, I get a "unable to cast object of type 'microsoft.win32/registryvaluekind' to type 'system.string' error

    If someone can just give me a screenshot of what the registry is supposed to look like with the keys in on Vista business, I could do it myself D:

  23. #273
    have you startet the unlocker with admin rights? i guess not...

    registry (extracted) looks like this (after the unlock, only difference is the InstallLocation value). this is for the 32bit version of windows.
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\THQ]
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\THQ\Dawn of War]
    "CDKEY"="classic key"
    "InstallLocation"="D:\\Programme\\THQ\\Dawn of War - Soulstorm\\"
    "CDKEY_WXP"="winter assault key"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\THQ\Dawn of War - Dark Crusade]
    "CDKEY"="dc key"
    "InstallLocation"="D:\\Programme\\THQ\\Dawn of War - Soulstorm"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\THQ\Dawn of War - Soulstorm]
    "CDKEY"="soulstorm key"
    "InstallLocation"="D:\\Programme\\THQ\\Dawn of War - Soulstorm"
    "W40KCDKEY"="classic key"
    "WXPCDKEY"="winter assault key"
    "DXP2CDKEY"="dc key"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\THQ\Dawn of War - Soulstorm\1.00.0000]

  24. #274
    Skippster
    Guest
    Worked fine, minus a small wrinkle I had to work out. (Been awhile, and my DoW and DC keys were written down under each other's headings, when I did a roundabout cut-paste job to shuffle them, I pasted and cut from the WA box, and it ended up creating a blank reg-key that SS then asked me for a key for.)

  25. #275
    GJ ! I don't see why anybody would insist on making a fairly simple program closed source.

    If anybodys interested in writing things to the registery(future unlockers ?). Heres a c++ class I wrote. It should point you in the right direction. Down with .NET ! even if it is easier


    Header
    Code:
    #include <windows.h>
    
    class registery{
    public:
    int write(HKEY key,char *,DWORD,char *,char *);//key,subkey,type,name,data
    int del(HKEY,char *);//key,subkey
    int read(HKEY key,char *,char *,DWORD *,DWORD *);
    /*key,subkey,name of key,reference to store the data,reference to store the size.*/
    };
    Source
    Code:
    #include "registery.h"
    #include <iostream>
    #include <string>
    
    int registery::write(HKEY key,char * subkey,DWORD type,char *name,char *data){
    HKEY hKey;
    PHKEY phandle = NULL;
    
    LPDWORD disp = NULL;
    
    if(RegCreateKeyEx(key,subkey,0,NULL,REG_OPTION_NON_VOLATILE,KEY_WRITE,NULL,&hKey,disp) != ERROR_SUCCESS)
    	return 0;
    
    if(RegSetValueEx(hKey,name,0,type,(const unsigned char *)data,strlen(data))!= ERROR_SUCCESS)
    	return 0;
    
    RegCloseKey(hKey); 
    return 1;
    }
    
    int registery::del(HKEY key,char *subkey)
    {
    if(RegDeleteKey(key,subkey) !=ERROR_SUCCESS)
    	return 0;
    
    return 1;
    }
    
    int registery::read(HKEY key, char *subkey,char *name,DWORD * data,DWORD * size)
    {
    	HKEY handle;
    	 if(RegOpenKeyEx(key,subkey,0,KEY_READ,&handle)!=ERROR_SUCCESS)
    	 {
    
    		 return 0;//failed to open
    	 }
    	if(RegQueryValueEx(handle, name, NULL,NULL, (LPBYTE)data,size) !=ERROR_SUCCESS)
    	{
    
    		return 0;
    	}
    	return 1;
    }
    Last edited by Brutal_Mauling; 5th Feb 09 at 4:23 PM.

  26. #276
    my app is and always was open source since not even 2 days after initial release in march 2008 >.<
    learn2read...

  27. #277
    I was congratulating you and talking about the guy who made the original unlocker. What do I get ? a misinterpretation and a childish response.

  28. #278
    sry that i got a little itchy, but you stated nowhere, that you talked about Bilge not me
    No offense meant, none taken, peace? :-)

  29. #279
    Is there anyway to uninstall this or reverse its effects? I've decided that I want to play vanilla DoW again, but my computer won't let me install it because it thinks its already installed and I only get the option to play (not install) when I put the CD in. I've already uninstalled SS.

  30. #280
    you have to go into the registryand delete the "InstallLocation" for DoW. After that, you can install classic again.

  31. #281
    leonatos32
    Guest
    um this comes up
    Download-Ticket abgelaufen.

  32. #282
    still works for me, i just tried. you may try the link to the sources, you will find the apps there too.

  33. #283
    Mulux
    Guest
    Edit: This is a great thing to use, thanks OP
    Last edited by Mulux; 18th Feb 09 at 11:54 PM.

  34. #284

    For the greater LOL

    This is simply too good to be answered privately (received via PM with title: "Help pls"):
    Quote Originally Posted by cenwei87
    Hi bro,

    After i open the SS race unlocker v1.1, there are 3 empty box that we need to put the cd-key.

    If i only have Dark crusade cd-key.. so is it that i only need to put the DC cd-key into that DC empty box?

    Would you kindly gave me the Classic and Winter Assault CD-Key, as i don't have the key with me?

    Please help me..I need your help..

    Thanks in advance
    well, sry non-bro, my keys are my keys and not to be shared with some random weirdo who obviously does not even own Classic and Winter Assault.
    Feel yourself kicked in the ass for so much stupidity.

    But to answer your first question: yes, fill in the DC key in the textbox for DC and leave the rest blank.

  35. #285
    mattering
    Guest
    this program is awesome..i did it in my laptop lol...but then now i cant unlock races on my desktop >.> running vista 64-bit...when i start SS, it will ask for CD keys >.> ... i entered them all correctly...but then it says DarkCrusade is no properly installed...also i didnt get any W40k.exe file...so my friend sent me that file and i renamed it to DarkCrusade.exe ... but then it didnt work...any solutions? i tried reinstalling SS...and when i reinstalled SS, i didnt use the unlocker but it still asks for the CD keys >.> its annoying me lol...any solutions? btw i want to unlock the races for multiplayer O_O...ok i just reinstalled...again and i got the message of an access denied to the registry...so i reinstalled...but no luck D: any solutions?
    Last edited by mattering; 22nd Feb 09 at 3:18 AM.

  36. #286
    from the first post:
    4) If you are running any version of Vista, you have to run the app with admin-rights (right-click on app -> run as admin)
    and you also have to use v1.1 >.<

  37. #287
    mattering
    Guest
    sweet it worked O_O ty belial u are awesome XD...i would send u a beer but no address..and also..i dont know how to send beers XD

  38. #288
    Member SpArTy's Avatar
    Join Date
    Jun 2007
    Location
    That place with the things and stuff.
    Hi just wondering if this app has timed out or something as I cant seem to run it anymore. I originally used it at the time of release and it worked perfectly. But since then I have unistalled and reinstalled SS several times. Now for some reason it isnt opening/running with anything. Suggestions?
    lol n00b

  39. #289
    get WinRAR oder 7zip to unpack the app. At the time of release i packed it as a zip iirc now it's a rar-file.

  40. #290
    Member SpArTy's Avatar
    Join Date
    Jun 2007
    Location
    That place with the things and stuff.
    Yes thanks I got it working.

  41. #291
    Hey, i just upgraded to the windows 7 SP or what ever it is, an before i used the unlocker to unlock all the races without needing the installations (I have the games, just with a 40 gig hard drive i cant blow it all on dow =( ) now with windows 7, it wont let the unlocker mess with the registry, i tried manually putting in the keys in the registry but to no avail, can anyone help me out?

    ok, i figured out how ot make it work, i make it run as administrator =D im an idiot lol,

    still got one problem, everytime I enter the keys and it comes up as it should work, then when i start the game it tells me that the cd keys are invalid... These are ligit keys that ive been using for years and its worked before but its not working now, anyone know what im doing wrong?
    Chaos Buildings Mod Member (ChaosLordX13)
    You may say, it is impossible for a man to become like the Machine. And I would reply, that only the smallest mind strives to comprehend its limits.

  42. #292
    Soulstorm needs access to the registry as well (it also needs admin rights).

  43. #293
    alright, ill try that

  44. #294
    ok thanks! it worked =)

  45. #295
    Ive downloaded it
    but where do i need to extract it to???

  46. Dawn of War II Senior Member Dawn of War Senior Member  #296
    Forum Fact Fairie Slow_Runner's Avatar
    Join Date
    Dec 2004
    Location
    Finland
    Anywhere you'd like.

    It'll work from where ever you extract it to.
    Disagree with a moderator? Read this.
    Quote Originally Posted by Maktaka

  47. #297
    Thanks Its just i didnt know if it had to be in the soulstorm file

  48. #298
    onespeed2011
    Guest
    Awesome! Big help to a guy in the desert with a damaged Gold edition pack.

  49. #299
    yes works great, real relief for lan partys!
    Colder than a wych's tit

  50. #300
    nile94
    Guest
    I get the error "/GraphicsConfig.exe could not be found..." with both versions!
    I have only soulstorm installed, but I have the Dawn Of war and the Dark Crusade CD keys (I bought that games). And now, when I start Soulstorm, it says "If you want to play with space marines, orks, eldar, chaos space marines in the multiplayer, enter your code...". When I enter my code, it says that dawn of war isn't installed, beacuse it is NOT installed! I can't install them because I've lost the CDs, I've only got the CDcases and the codes!

Page 6 of 7 FirstFirst 1234567 LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •