Results 1 to 6 of 6

Error 10242

  1. #1
    Downunder99
    Guest

    Error 10242

    I downloaded and installed latest patch and now have the 10242 error message...complete valid CoH inst could not be found. A previous post reply said to ask "Steam Forums". Why "Steam Forums"...I got the game from a retail outlet and never had issues with previous patches other than the increase in lag.

    What will steam do that Relic cant?

    Also, I found this "solution" in a google search...not sure if there is merit in the solution...


    Company of Heroes error 10242 - solution

    --------------------------------------------------------------------------------

    Just in case someone else is searching for the answer to this question...

    I just moved my CoH install to a new system by copying the folder over rather than going through an evening of re-installation. Everything worked great on the new system until the 2301 patch showed up. Then it complained and gave me an error 10242 when I tried to install the patch.

    It pained me for awhile and then I decided to dig in and figure out what was making it fail. It turned out to be a missing registry entry.

    Adding this uninstall section fixed the problem. If you are doing this yourself, make sure the version in DisplayVersion matches your install.

    Code:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Company of Heroes]
    "DisplayName"="Company of Heroes"
    "UninstallString"="\"C:\\Program Files\\THQ\\Company of Heroes\\Uninstall_English.exe\""
    "InstallLocation"="C:\\Program Files\\THQ\\Company of Heroes"
    "Publisher"="THQ Inc."
    "DisplayVersion"="2.300.0"
    "DisplayIcon"="\"C:\\Program Files\\THQ\\Company of Heroes\\Uninstall_English.exe\""Cut and paste the above into a file and import it into your registry with regedit. BE CAREFUL with regedit, doing it wrong can really mess up your system.

    I hope someone searching
    the net finds this and is helped.[/I]

  2. #2
    Kmansp
    Guest
    I'm pretty much in the same boat. I copied the whole folder over to my external drive and reinstall everything on my computer. I followed your example above and it says it was added successfully to the registry, but I'm still getting a message saying it does not detect a valid installation, blah blah blah etc. I even tried editing the reg entry so that it shows it's on the E: drive, and verified the directories and version number are all correct. Still nothing. What could i be doing wrong?

  3. #3
    Relic Entertainment Haven0's Avatar
    Join Date
    Mar 2008
    Typically you will not be able to move the entire directory of a game and have it still work, there are too many broken links and registry entries. If you want to reformat but save your personal game data you only need to back up your CoH folder in your MyDocs -> My Games folder.

    There really isn't any reliable way around reinstalling CoH if you choose to reformat your OS.
    - Haven0
    "Deus est in Suo caelo, omnia recta mundi."

  4. #4
    Downunder99
    Guest
    I think the issue I had was that I used a 3rd party registry cleaner that wiped a lot of the un-install stuff from the registry and it corrupted CoH. Perhaps others have had the same issue.

    I restored my computer to an earlier point in time using system restore and that seemed to fix the problem. This raised another (non-critical) issue that Ill raise in a seperate post.

  5. Technical Help Senior Member Modding Senior Member Homeworld Senior Member  #5
    www.relicnews.com ÜberJumper's Avatar
    Join Date
    Sep 1999
    Location
    South Surrey, BC Canada
    DownUnder:

    The steam post you probably refered to was most likely because a user tried to run the patch against their Steam install of the game, and that wouldn't have been able to patch it properly. Steam provides the patch, which is why we would have directed them to contact steam.

  6. #6
    Jagmas
    Guest
    My game has been on my system and i've played it fine before trying to grab whatever patch it tries to put on. Now all of a sudden it doesn't seem to think my install is valid. It was a fresh install on the system since i've had it and I suspect the problem is because I only own COH and not the addon. If my install disc can see that the install path is good and does not ask me to install the game when I insert it, why does the patch not see this?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •