Results 1 to 9 of 9

Problem with Homeworld 2 graphics

  1. #1
    Angellus
    Guest

    Problem with Homeworld 2 graphics

    Hi, I recently installed homeworld 2 on my Windows xp rig again, I've played homeworld on this pc before (about a year ago) without any problems, but after I chose for a game vs the cpu with the new install I got this view:

    ((Please refer to the 5th post in this thread for the pictures, posting pictures in the first post is not allowed by this forum.))

    Where everything is black, exept for strangely enough the mining asteroids.


    EDIT:
    I would like to add that I have a Radeon x600 graphics card with the newest drivers (catalyst 9.3) installed.

    I have tried reinstalling the game, but it wont change anything.


    EDIT again:
    Also, I run version 1.1, with no mods, just a clean, fresh install with update.
    Last edited by Angellus; 20th Jul 09 at 4:14 AM. Reason: Referer to 5th post for pictures.

  2. #2
    Try an older version of the radeon drivers or run the game with the -noVBO command line switch. There seems to be a problem with the newer radeon drivers and HW2. That should fix your problem.
    Babylon 5: War Without End Official Site.

    "I keep telling you people that it's only a build animation, NOT a hyperspace animation." - Me, about the Babylon 5 mod hyperspace build animation.

  3. #3
    Angellus
    Guest
    The command worked, you can not inmagine how gratefull I am!



    EDIT:
    Just curious, what does -noVBO do?

  4. Forum Subscriber  #4
    You are now allowed to put in pictures and hyperlinks, so if you could post what it looks like that would help future troubleshooting of your same problem. The forum prevents you from doing so on your first post to minimize spambots.

  5. #5
    Angellus
    Guest
    these are the two pictures I had (I tried again this morning, to find some weird distortion on the background)

    1.




    The distortion:
    2.



    The solution was to put the command '-noVBO' on the desktop shortcut.
    Thanks for helping me

  6. #6
    Yeah, no problem. It seems a lot of people have run into that problem lately, so it's good that we're getting the solution posted in an easy to find place so people can get to play again.

    The -noVBO command disables the use of Vertex Buffer Objects.

    I'm not sure what that entails exactly, but you can find the description of this and most other possible command line switches at this site: http://hw2wiki.net/wiki.hw2.info/Com...arameters.html

  7. #7
    Thank you so much for solving this problem.

    My problems were slightly different:
    The textures of the ships where invisible, but the lights off the ship still blinked. Also the background (same blocks), and the radarcompass wasnt very 100%.

    I had this problem with a RADEON 9600 PRO (256 MB Ram).
    I used a catalyst 10.2 driver (so its the driver).

    And the solution of adding: \Homeworld2\Bin\Release\Homeworld2.exe -noVBO
    worked.

    Keywords: Glitch, bug, texture, videocard, radeon, homeworld 2, invisible, black.

  8. Technical Help Senior Member Modding Senior Member Homeworld Senior Member  #8
    www.relicnews.com ÜberJumper's Avatar
    Join Date
    Sep 1999
    Location
    South Surrey, BC Canada
    That wiki entry has a huge amount of HW1 command line switches in it.

    There's a much shorter list here.

    http://forums.relicnews.com/showthread.php?t=16267

  9. #9
    Member Citizen M's Avatar
    Join Date
    Aug 2010
    Location
    Toronto, Ontario, Canada
    I just found this topic on a Google search for a problem nearly identical to this. I'm currently playing Homeworld 2 on XP with 4.4 Catalyst drivers in order to make the game function. I'll try new drivers, but use this command function and see if it works. Thank you all so much for posting about this issue.

    Btw, it's been about 8 or 9 years since I've been on relicnews and it's surreal to see some old member names I still recognize from the Homeworld pre-release days (Uber, my gawd, you're still here!). I can't even remember what name I used when I was here way back when. Perhaps if any of the old forums are archived I can take a stroll down memory lane

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •