Results 1 to 3 of 3

Fail to install Retribution via Steam

  1. Tabletop Senior Member  #1
    Journalist in War BrianGeneral's Avatar
    Join Date
    Jan 2004
    Location
    Mad about DoW in Hong Kong

    Fail to install Retribution via Steam

    So I got my copy today, and started to install the game. But after I enter the CD key on Steam for activiation, it simply says "cannot install components via steam" or something like that, then I tried to re-enter the Key it says my product has been activiated, but Retribution isn't installed at all.

    Can anyone tell me how to solve this mess?

    Edit: I just retried and it simply says unable to reach Steam network but my network is obviously fine right now, and it still says I owned the game (but I obviously can't play it since it's not even installed, and it's not in my Game Library). Is it Steam's problem or else?

    ----------

    Appaently the problem has been solved somehow. Probably the old SC1's DNZ, but that had been installed for some days and I had no problem to play CR or DoW2 before. Strange......
    LET THE GALAXY BURN!! IRON FOR THE IRON GOD!
    Arise, my Iron Legionnaires!!
    Only argue with me about 40K gaming after reading this, about Tau after this, this and this, and about Space Marines after that.Remember!

  2. #2

    Working Solution

    1.Start up the steam client and add game: Enter your valid serial key.
    Once completed the steam client will ask to install the game, cancel and exit out from steam. (make sure its not running in the back ground)

    2.insert the game DVD in to your drive.

    3.start up a command prompt cmd.exe
    Browse to your steam directory for example -
    C:\Program Files (x86)\Steam

    Then run the following command: steam.exe -install d: (D: BEING THE LETTER OF YOUR DVD DRIVE)

    4. Installation should start, click to continue and the game files will start to copy from the CD.

    Hope this helps.

  3. #3
    It actually worked! Good thing I remember my old DOS skills. Not the OP, but thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •