Results 1 to 3 of 3

Homeworld: Cataclysm has off-center display.

  1. #1

    Homeworld: Cataclysm has off-center display.

    I decided to boot up Homeworld: Cataclysm after having a blast in Homeworld Remastered Collection, but I've run into some... unfortunately familiar... problems.

    The problem seems to be around the display settings. I'm not a stickler for widescreen gaming on a modern PC (I just played Homeworld 1 Classic with 1024x768 settings packaged with the game) so I'm not going to bother with getting it widescreen unless it's a perk I can figure out. Anyway, back to the problem. First time I booted up the game (running v1.01), everything was fine. I put it on OpenGL 1024x768 (32) and ran the tutorial to see if things worked. All things went smoothly. I then wanted to playtest the D3D settings, so I went back to the Video settings and changed it to D3D 1024x768 (32). The game readjusted the display but this time the game's main menu was off-center. Things were arranged in such a way I couldn't see the "Quit" button in the bottom-right of the screen. Now I went back into Video (I could see the left-hand edge of the button), and managed to select something else. I hit "A" for Accept (as I couldn't reach the button) and the game exited to Windows. The icon disappeared from the program bar but continued to persist in the Task Manager.

    I then reopened Cataclysm and it was on a low resolution, still off-center to the right and down a bit. I've tried OpenGL settings, 16-bit, 32-bit, lower resolutions, higher resolutions, and all the same using Software and D3D, and each time I hit "A" the game goes to adjust the settings only to quit to windows, lose its icon, yet persists in the Task Manager.

    I've tried reinstalling the game, even deleting the C:\Sierra\Cataclysm folder and registry keys, to no avail. The same off-center display happens, followed by my trying to change the Video settings, followed by exiting to Windows, no Cataclysm icon in the tray, and yet it persists in Task Manager. I've also tried editing the Registry Keys for the display settings, changing it to 1024x768, 800x600, 1366x768 (my native resolution), changing the openglget register to a different dll - nothing has worked. The same thing happens every time: off-center display, an attempt to change... you know the drill by now.

    Is it possible to do a "clean install" of the game? Because the first install seemed to work just fine. I've had this problem with Cataclysm before, even on my older computers. This off-kilter display problem is really weird and seems stubborn if not impossible to solve.

    System specs:

    Windows 10
    NVidia GPU (but using Intel dedicated graphics)
    4GB RAM
    2GB Dedicated VRAM
    Above and beyond what Cataclysm requires (as I said - it ran beautifully on the first go. Why can't it get back to that?)
    Last edited by MrFox88; 28th Mar 16 at 9:34 PM. Reason: clarifying problem in thread title

  2. #2
    I just attempted to use one of the switches by creating a shortcut for the game and then modifying its properties. I used the "/safeGL" switch. No change.

  3. #3
    Solved: Tried using the switch "/sw" which resets the game's settings to software defaults. I'll leave this post here in case anyone else has noticed the same problem, unless admins want to get rid of it.

    Thanks for your help I guess? I did find the switch list in the forums elsewhere on the forums, after all. It did take a while to sift through them all so I guess this thread can help others who don't have the patience?

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts