Results 1 to 5 of 5

Need help with OpenGL !!!!

  1. #1
    ep691_ar
    Guest

    Need help with OpenGL !!!!

    I cant get Homeworld to work with opengl , i've tried with glsetup, i've tried copying opengl32.dll into 3dfx opengl folder, and nothing, i know my card supports opengl, its a Savage 4 with 32mb, Please help me!!!!!!!

  2. Technical Help Senior Member Modding Senior Member Homeworld Senior Member  #2
    www.relicnews.com ÜberJumper's Avatar
    Join Date
    Sep 1999
    Location
    South Surrey, BC Canada
    Ok...

    If you have Win95,ME,2k or XP there's a strong chance that OpenGL won't work at all.

    IF you have win98 then you SHOULD be able to get OpenGL working.

    Please post a more detailed system spec including:

    Game
    CPU
    Memory
    Motherboard
    Video Card
    Sound Card
    Additional Hardware
    Operating System
    DirectX Version
    Game Video Mode and Resolution
    Desktop Video Mode and Resolution


    Thanks!

  3. #3
    ep691_ar
    Guest
    Game ----> Homeworld v 1.3
    CPU ------> Celeron 300mhz
    Memory --> 96mb
    Motherboard---> I'dont know, it could be ALI??, on board sound
    Video Card -----> Savage 4 32mb
    Sound Card-----> Onboard, CMI8330
    Aditional Hardware--->????
    Operating System----> Windows 98
    DirectxX Version------> DirectX 8 english
    Game Video Mode and Resolution---> In D3D, supports 1024x768 32bits, thats what my monitor supports.
    Desktop video Mode and Resolution--->same as avobe.

    I've set the same video resolution in the game and in the desktop, but the problem, is that the opengl option inside the game doesn't appear, i can only choose between software and D3D, i know my video card supports opengl, i've played Quake3, Half Life, Star Trek Voyager Elite Force.

    I've read that tere is a parameter for the command line to force Homeworld to use default opengl driver, but i cant get it to work, i tell's me that it's not a correct parameter.

    I love the game in D3D, but with my machine, i want to use opengl, that is faster than D3D. And i dont want to use software mode.

    I hope i gave you enough info. Thanks.

  4. #4
    cwmark
    Guest

    OpenGL with W2k and HW and HWC doesn't work anymore

    I'm suffering from the same problem as well. No OpenGL for HW and HWC under Windows 2000. Tried the usual and recommended fixes (new drivers, refresh fixer, and copying opengl32.dll file, etc.) - still no luck. Everything worked fine under Win98, but silly me wanted to use that second CPU and upgraded to Windows 2000.

    System specs:
    Dual P3/1Ghz
    512mb DDR PC2100 RAM
    Iwill DVD266-R motherboard with VIA 266 chipset
    Hercules Prophet 3 (Geforce 3) video card
    60Gb ATA100 7200rpm hard drive
    fresh install of Win2K and service pack 2

    BTW, none of my other OpenGL games seem to work either.

    Any help would be appreciated!

  5. Technical Help Senior Member Modding Senior Member Homeworld Senior Member  #5
    www.relicnews.com ÜberJumper's Avatar
    Join Date
    Sep 1999
    Location
    South Surrey, BC Canada
    K...

    ep691... update your version of Homeworld to the latest, and try these command line switches.

    /safegl /dev gl /640 /noglddraw

    cwmark, you could *try* to force the card to use openGL using the HW Video Tweaker. Sadly, the notes I had to use it have been lost to the ages, but basically, it modifies the devstats.dat file using the hardware identification of your card to enable or disable certain features. No one that has Win2k has had any luck that I know getting Homeworld to run in OpenGL on Win2k however :-/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •